Arizona Fly Fishing Forums  

Go Back   Arizona Fly Fishing Forums > Arizona Fly Fishing > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 04-30-2014, 09:53 PM
RiseToADry's Avatar
RiseToADry RiseToADry is offline
Member
 
Join Date: Oct 2012
Location: Scottsdale, AZ
Posts: 59
Just wanted to post the results of my adventure this past weekend.

Went to CC on Sunday for the first time and fished for about 6 hours but didn't land any. It was pretty cold and windy so there wasn't a lot of surface action. My nymphing skills aren't extraordinary so I left with my tail between my legs and the nasty smell of skunk. Oh well.

Overall I was pretty impressed with the water, it was pretty diverse with a lot of riffle runs and deep slow pools. Definitely want to go back when the weather warms up.
Reply With Quote
  #12  
Old 05-01-2014, 09:49 AM
BtheBlue's Avatar
BtheBlue BtheBlue is offline
Senior Member
 
Join Date: Dec 2013
Location: Oahu
Posts: 186
In the past, I've done well with a little nymph rig at CC but did get a very hefty brown on a hopper too. Too bad about the weather but thanks for the report.
Reply With Quote
  #13  
Old 05-01-2014, 09:52 AM
BtheBlue's Avatar
BtheBlue BtheBlue is offline
Senior Member
 
Join Date: Dec 2013
Location: Oahu
Posts: 186
My nymphing skills aren't extraordinary so I left with my tail between my legs and the nasty smell of skunk. Oh well.


oh, and my nymphing skills are not great.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Logos, Trademarks are property of their owners. Other content Copyright 2006-2015 azflyandtie.com . All Rights Reserved.